Nevron Open Vision Documentation
Diagram Command Bars via Code

If you are building a cross-platform NOV application, you can't use the Visual Studio designer, so you should customize the command bars via code.

Hiding Menus and Toolbars

To hide an command bar or a command bar item use the corresponding Get... method of the NDrawingViewWithCommandBars or NDrawingViewWithCommandBarsControl class and set its Visibility property to Collapsed:

The following code snippet hides the "View" menu and the "View" toolbar, as well as the "File -> Import" menu item and its sub menu items.

Hide menus and toolbars
Copy Code
// Hide the "View" menu drop down
nDrawingViewWithCommandBarsControl1.GetMainMenuBar()
    .FindMenuDropDownByText(NDiagramCommandBarBuilder.MenuViewName).Visibility = ENVisibility.Collapsed;

// Hide the "File -> Import" menu item
nDrawingViewWithCommandBarsControl1.GetMainMenuBar()
    .FindMenuDropDownByText(NDiagramCommandBarBuilder.MenuFileName)
    .Items.FindByText(NDiagramFileMenuBuilder.MenuImportName).Visibility = ENVisibility.Collapsed;

// Hide the "View" toolbar
nDrawingViewWithCommandBarsControl1.GetToolBar(
    NDiagramCommandBarBuilder.ToolbarViewName).Visibility = ENVisibility.Collapsed;
Note that instead of using string literals like "View", it is better to use the string constants defined in the NDiagramCommandBarBuilder class to get menu and toolbar names as shown in the code snippet above.
Removing Commands

To remove all widgets associated with specific commands from the commanding UI, use the RemoveCommands method of the drawing view with command bars.

Remove commands
Copy Code
// Create an array of commands to remove
NCommand[] commandsToRemove = new NCommand[] {
    NDrawingView.OpenCommand,
    NDrawingView.SaveAsCommand,
    NDrawingView.SaveCommand
};

NDrawingViewWithCommandBars drawingViewWithCommandBars = new NDrawingViewWithCommandBars();
drawingViewWithCommandBars.RemoveCommands(commandsToRemove);

Always use the RemoveCommands item to remove individual menu and toolbar items, unless the menu item has sub items. In that case use the GetMainMenu method of the menu bar, then FindMenuDropDownByText to get the menu drop down and finally Items.FindByText to get the item with sub items, which you want to hide as shown in the previous section.

Modifying Builder Collections

If you want to remove a given toolbar or menu from the builders, you can easily do so by using the Remove method of the ToolBarBuilders and MenuDropDownBuilders collection of the diagram command bar builder respectively. You can get or remove builders by name.

The names of all diagram menu and toolbar builders are exposed as constants in the NDiagramCommandBarBuilder class. For example, to remove the "File" menu and the "Standard" toolbar of a command bars based diagram UI, you can use the following piece of code:

Remove Toolbar and Menu Builders
Copy Code
commandBarBuilder.MenuDropDownBuilders.Remove(NDiagramCommandBarBuilder.MenuFileName);
commandBarBuilder.ToolBarBuilders.Remove(NDiagramCommandBarBuilder.ToolbarStandardName);

In order to add or insert your own toolbar or menu drop down builder, you can use the Add or Insert methods of the corresponding builder collection respectively.

Add Custom Toolbar and Menu Builders
Copy Code
commandBarBuilder.MenuDropDownBuilders.Insert(1, new CustomMenuBuilder());
commandBarBuilder.ToolBarBuilders.Insert(0, new CustomToolBarBuilder());
Custom Menu Builders

To create a custom menu builder, you should create a class, which inherits NMenuDropDownBuilder:

Create custom menu drop down builder
Copy Code
public class CustomMenuBuilder : NMenuDropDownBuilder
{
    public CustomMenuBuilder()
        : base("Custom Menu")
    {
    }

    protected override void AddItems(NMenuItemCollection items)
    {
        // Add the "Copy" menu item
        items.Add(CreateMenuItem(Nevron.Nov.Presentation.NResources.Image_Edit_Copy_png, NDrawingView.CopyCommand));

        // Add the custom command menu item
        items.Add(CreateMenuItem(NResources.Image_Ribbon_16x16_smiley_png, CustomCommand));
    }
}
Custom Toolbar Builders

To create a custom toolbar builder, you should create a class, which inherits the NToolBarBuilder:

Create custom toolbar builder
Copy Code
public class CustomToolBarBuilder : NToolBarBuilder
{
    public CustomToolBarBuilder()
        : base("Custom Toolbar")
    {
    }

    protected override void AddItems(NCommandBarItemCollection items)
    {
        // Add the "Copy" button
        items.Add(CreateButton(Nevron.Nov.Presentation.NResources.Image_Edit_Copy_png, NDrawingView.CopyCommand));

        // Add the custom command button
        items.Add(CreateButton(NResources.Image_Ribbon_16x16_smiley_png, CustomCommand));
    }
}

To replace the original "Standard" toolbar builder with the custom one, use the following code:

Replace the "Standard" toolbar builder
Copy Code
NDiagramCommandBarBuilder commandBarBuilder = new NDiagramCommandBarBuilder();
int toolbarIndex = commandBarBuilder.ToolBarBuilders.IndexOf(NDiagramCommandBarBuilder.ToolbarStandardName);
commandBarBuilder.ToolBarBuilders[toolbarIndex] = new CustomStandardToolbar();
See Also
Send Feedback